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QT Application Development for phyBOARD-WEGA-AM335x:

     In this Manual, we are going to describe how to use Qt application for development. 

1. First chapter      – Deals with the installation of Qt Creator. 

2. Second chapter – Explains how to configure QT creator for cross compilation. 

3. Third chapter     – Describes how to write an application using Qt Creator and 

4. Fourth chapter   – Describes Qt Creator with UART Demo application.

1. Application development using Qt Creator:

With the help of example projects, we will teach you how to work with Qt. 

Explain how to run Qt application on target (ARM architecture), in Linux (Ubuntu) environment.

1.1. Qt Creator Installation

Qt in linux 
First of all install Qt Creator with the help of Ubuntu Software Center 

Enter Qt Creator in the search box in the right top corner (in Ubuntu Software Center).
Install it (see the below image)

                                 Figure 1.1
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1.2. Network Settings(Host and Target)

In Host :

Click on Dash Home and enter as Network Connections and click.

Figure 1.2.1

Here click on Add label and give a connection name as shown below.

 

Figure 1.2.2
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Here you need to select Method as Manual and click Add label again do ip settings then Save as 
shown below.

Figure 1.2.3

Then finally you will get successfully as below if your Connection Established correctly.

Figure 1.2.4
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In Target :

Do the ip settings in your target as shown below figures.

Figure 1.2.5
Now set ip usig ifconfig eth0 192.168.1.196 up shown in below figure

Figure 1.2.6
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Figure 1.2.7
 

2. QT Creator Configuration for phyBOARD-WEGA-AM335x

2.1. Configuring QT Creator for Cross Compilation

Now let’s setup QT creator to configure qmake. From the QT creator main menu shown below:
    
Select the following:  

Tools -> Options... 

On the left side vertical menubar click Build & Run

Click the Qt Versions tab under Build & Run 

Remove any versions that may already exist to make sure you start with a clean configuration 

Click Add... on the right 

Note: Here navigate to the path of qmake in our PC (refer section 2.3.2).

Select qmake then click on Open 

Double click on Version Name and give the Qt Version a descriptive name in below  image .
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                                                          Figure 2.1.1

Export the Tool chain Path (refer 2.2.3)

Click the Tool Chains tab under Build & Run 

Click Add in the top right and add a GCC  

For Compiler Path select Browse 

Navigate to /home/<user>/work/phytec/src/arm-cortexa8-linux-gnueabihf/bin

Note: Here navigate to the path where you have exported the tool chain
Select Compiler Path: Click on Browse and select path of compiler 
/home/<user>/work/phytec/src/arm-cortexa8-linux-gnueabihf/bin/arm-cortexa8-linux-
gnueabihf-gcc.

Debugger: Click on Browse & select path of Debugger  home/<user>/work/phytec/src/arm-
cortexa8-linux-gnueabihf/bin/arm-cortexa8-linux-gnueabihf-gdb, as shown below.

© PHYTEC Embedded Pvt. Ltd 2014 9 Revision no. 1.0



  

Figure 2.1.2

Now let’s setup our Target.  While still in the Tools -> Options menu 

On the left side of the window, select the Linux Devices tab 

 

Figure 2.1.3

In Linux Devices: click the Device Configurations tab.

Click Add... in the top right and select Generic Linux device and click on Start Wizard 
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Figure 2.1.4

The Device Configuration Wizard Selection Dialog box comes up,
Change the name Generic Linux Device to give the device a unique name: AM335x, 

Type in the IP address Box as – 192.168.1.196 (For your target),

In the Box - The Username to log into device, write entry as root, 

Make sure Authentication type is Password, but leave the password field blank. 
Click next and click Finish 

Figure 2.1.5

Now you should see Device test finished successfully, so you can close the window
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.

Figure 2.1.6

Now we need to setup an SSH key so that the host can communicate with the target

Still under the Device Configurations tab click "Generate SSH Key...” 

Select Key size: 1024 

Key algorithm RSA 

Then click Generate SSH Key in the SSH Key Configuration dialog box 

Figure 2.1.7
Click Do not Encrypt key file
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Figure 2.1.8

Then click Save Public Key... 

Figure 2.1.9

Just use the default name id_rsa.pub and Click Save and Click Close to close the Generate SSH 
Key window.
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Figure 2.1.10

Under the Device Configurations tab now click Deploy Public Key... 

Figurer 2.1.11

Select the file just generated (should be under /home/<user>/.ssh) 

IMPORTANT : You may need to right click and select show hidden files or Ctrl+h
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Figure 2.1.12

Select the file id_rsa.pub and click on Open, shortly a window should show up saying 

"Sucessfully" 

 

Figure 2.1.13
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Figure 2.1.14

Close the window and Click OK to exit the Linux Devices Window.

2.2. Target Setup

Host Setup - First open the terminal (ALT+CTRL+T).

2.2.1. Toolchain Installation:

This section explains how to Install prebuilt toolchain binaries on the Host.  Where as, building
 of Toolchain is explained in build system section.

2.2.2. Downloading the Toolchain:

Download the toolchain from the public ftp of PHYTEC from the link below.
ftp://ftp.phytec.de/pub/Products/India/phyBOARD-WEGA-
AM335x/Linux/PD14.0.0/tools/toolchain/arm-cortexa8-linux-gnueabihf.tar.bz2

2.2.3. Export the Toolchain to Shell Path:

Extract the toolchain that has downloaded, from terminal issue the following commands:
$ mkdir ~/work 
$ cp arm-cortex8-linux-gnueabihf.tar.bz2 ~/work
$ cd ~/work
$ tar –xvf arm-cortex8-linux-gnueabihf.tar.bz2 

Now write a script that export the target Architecture and toolchain prefix as below. 

$ vim env.sh 
 

#!/bin/sh 
export PATH=$PATH:/home/<user>/<path to toolchain bin> 
export ARCH=arm 

                        export CROSS_COMPILE=arm-cortexa8-linux-gnueabihf- 

Save and exit from the editor. Execute the script by issuing 

$ . env.sh
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Note: The command is “dot space env.sh”. Execute the above command for shell where you are 
trying to start compilation of Qt.

Check whether the toolchain path is set or not by issuing

 $ echo $PATH

Above command displays the entire paths that are added to Shell PATH variable separated by 
colon ‘:’. See if your path is printed on the terminal. If you are not able to see your toolchain path 
repeat the steps from the beginning of this section.

2.3. Building qmake using QT:

Method:1

Download QT version from the following link 
http://download.qt-project.org/official_releases/qt/4.8/4.8.5/qt-everywhere-opensource-src-
4.8.5.tar.gz

Compile the qt-everywhere-opensource-src-4.8.5 source file 
$ cp qt-everywhere-opensource-src-4.8.5.tar.gz ~/work

$ cd ~/work

$ tar -xvf  qt-everywhere-opensource-src-4.8.5.tar.gz

$ cd qt-everywhere-opensource-src-4.8.5

$ vim mkspecs/qws/linux-arm-gnueabi-g++/qmake.conf

change arm-none-linux-gnueabi to  arm-cortexa8-linux-gnueabihf
save and exit 

Execute the following configuration command

$./configure -opensource -confirm-license -release -rpath -no-fast -no-sql-ibase -no-sql-mysql -no-
sql-odbc -no-sql-psql -no-sql-sqlite2 -no-qt3support -no-mmx -no-3dnow -no-sse -no-sse2 -no-
sse3 -no-ssse3 -no-sse4.1 -no-sse4.2 -no-avx -no-optimized-qmake -no-nis -no-cups -no-pch-
reduce-relocations -force-pkg-config -prefix /opt/qt-cross -no-armfpa -make libs -nomake docs-ittle-
endian -embedded arm -qt-decoration-styled -depths all -xplatform qws/linux-arm-gnueabi-g++

$ make 

$ sudo make install 

check the binary file in /opt/qt-cross

$ ls /opt/qt-cross/bin

Method-2:

use prebuilt qt-cross provided by Phytec

$ sudo cp qt-cross-hf.tar.bz2 /opt

$ cp /opt

$ sudo tar -xvf   qt-cross-hf.tar.bz2 

$ ls /opt/qt-cross/bin

Completed , Now use the qmake path for cross-compiling you application in QT-Creator.
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2.4. Setting Serial Console (Minicom)

$ sudo minicom -s
Select the option serial port setup from menu on terminal and press 'Enter'

                                    Figure 2.4.1

Using the options at left; make the setting as shown in the figure 2.4.2 
For ex: Serial device – dev/ttyS0, first press ‘A’ the cursor blinks at the particular line then 
change the device name to /dev/ttyS0 and press ‘ENTER’. 

 

Figure 2.4.2

After  making  all  changes  like  baud  rate  -  115200,  hardware  flow  control  -  No etc.,  press 
‘ENTER’ to come out from the screen.Now, select the ‘Save setup as dfl’ it saves the setting as 
default. Have a look at the Screenshot below:
                 

Figure 2.4.3
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Now select ‘Exit’ as below:

             

Figure 2.4.4

Now minicom terminal is ready to be used.

3. Application development

3.1. Simple Demo Application: 

Open a New Project

Under Forms, double click on phytec.ui - this will bring up the widget editor. 

Figure 3.1.1

Find the label widget in the category of display widgets, left click and drag it on to the User 
Interface (UI). 
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Figure 3.1.2

Type any name such as “PhytecIndia” into the label widget and stretch out the borders so you can 
see all the letters

Figure 3.1.3

File->Save phytec.ui

Now we need to check and update the build and run settings: 

On the left side vertical menubar select Projects  

Select the Build Settings tab and select ''Qt 4.8.5(sysroot-cross) Release'' in Edit build 
configuration.
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Figure 3.1.4

Now under the Projects Mode select the Run Settings tab 

Under Deployment click Add and select Deploy to Remote Linux Host 

However you see the <no target path set> error

 

Figure 3.1.5

To fix the <no target path set> errors do the following: 
Click on Edit on the left side vertical bar and click on Phytecindia.pro 
Add the two lines below to the bottom of Phytecindia.pro as shown in the screen shot below

target.path  +=  /home/phytec
INSTALLS  += target
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Figure 3.1.6

Select File -> Save 

Click on Projects on the left side vertical bar and you should now see the error is gone and 
replaced with /home/phytec 

Now in the Run portion: Select Add -> terminal (on Remote Generic Linux Host)

 

Figure 3.1.7

Finally, run the application:

Note: If application is not running add “-qws” to the Arguments section in Run settings.
The Output can be seen in LCD display as shown below.
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3.2. Uart Application

Download the Source code of Uart from the following link:

ftp://ftp.phytec.de/pub/Products/India/phyBOARD-WEGA-
AM335x/Linux/PD13.0.0/src/apps/Qt_uart.tar.gz

Select File-> Open File or Project 

Open the obserial.pro file in the Qt_uart folder, as shown in the screenshot below:

Figure 3.2.1

Click on Edit on the left side vertical bar and click on obserial.pro
Add the below lines at the bottom of obserial.pro file as shown in the screen shot below.
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Figure 3.2.2
target.path += /home/phytec

INSTALLS += target

Select File -> Save 

Now we need to check and update the and run settings: 
Now under the Projects Mode select the Run Settings tab 

Under Deployment click Add and select Deploy to Remote Linux Host 
Now in the Run portion: Select Add -> obserial (on Remote Generic Linux Host)

Figure 3.2.3

Now on host side (power up the target board and make proper settings and make sure Ethernet 
wire is connected on the target side).

To login to the target give the following command

$ ssh root@< ip-address of target>

  

Figure 3.2.4
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Now you are in target

Figure 3.2.5

Go to the path which we mentioned in bottom of the .pro file in Qt creator

i.e,target.path += /home/<user> (see the following image.)

Figure 3.2.6
$ cd /home /<user>

 

Figure 3.2.7

Now execute the output file $./obserial -qws

$ ./obserial -qws

Figure 3.2.8
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Now you will see the console in LCD display.

First, connect the usb hub to the target and then connect Mouse and Keyboard to that hub. Click 
on the setting icon (which is third icon in the below row)

 

Figure 3.2.9

 Set the Baud rate (The baud rate settings in LCD display should match the baud rate in 
serial port settings in target)

NOTE:Set the serial port settings in LCD display (preferably ttyO1)
Click on the Apply button.

Next, Click on the icon (connect to serial port) which is first in the row. 
Now, type any letters on keyboard which is connected to USB-Hub, it visible on terminal of the  
LCD display:

   
Figure 3.2.10

Open the minicom and log-in to the board
The same will be displayed on the minicom as below: 

Figure 3.2.11
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                                                Get the dialog going ...
                           ... and stay in touch

India

PHYTEC Embedded Ltd. 
#16/9c 3rd Floor, 3rd Main

8th Block, Opp. Police Station
Koramangala, Bangalore-560095

Tel.: +91-80-40867046/49
www.phytec.in

Germany

PHYTEC Messtechnik GmbH
Robert-Koch-Straße 39

D-55129 Mainz
Tel.: +49 6131 9221-32
Fax: +49 6131 9221-33

www.phytec.de
www.phytec.eu

America
PHYTEC America LLC

203 Parfitt Way SW, Suite G100
Bainbridge Island, WA 98110

Tel.: +1 206 780-9047
Fax: +1 206 780-9135

www.phytec.com

France
PHYTEC France SARL

17, place St. Etienne
F-72140 Sillé le Guillaume

Tel.: +33 2 43 29 22 33
Fax: +33 2 43 29 22 34

www.phytec.fr
.......................................We are looking forward to hear from you! ............................................  
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