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QT Application Development for Cosmic-AM335x 

In this Manual we are going to describe how to use this Qt application for development.  

Our first chapter is dealing with the installation of Qt Creator and in second chapter we will explain 

 how to configure QT creator for cross compilation. In our third chapter we will describe how to  

write an  application(demo) using Qt Creator and also a UART application . After going through this  

manual  you will not only familiar with Cosmic-AM335x  board as well as you will also have an idea  

how to use Qt for application development. 

 1. Application development using Qt Creator 

With the help of example projects, we will teach you how to work with Qt.we explain 

how to run Qt application on target(ARM architecture),in Linux(Ubuntu) environment. 

1.1. Qt Creator Installaion 

Qt in linux  

First of all install Qt Creator with the help of Ubuntu Software Center  
 
Enter  Qt Creator in the search box in the right top corner(in Ubuntu Software Center). 
Install it(see the below image) 
 

 
 

Figure 1.1 
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2.QT Creator Configuration for Cosmic-AM335x 

Note:Before starting the procedure, power up the Cosmic board and set the ip address  

 to the target.  

2.1.Configuring QT Creator for Cross Compilation 

Now lets setup QT creator to configure qmake. From the QT creator main menu shown below    

select the following:   
 
Tools -> Options...  

 
On the left side vertical menubar click Build & Run 
 
Click the Qt Versions tab under Build & Run  
 
Remove any versions that may already exist to make sure you start with a clean configuration  
 
Click Add... on the right  

 
Navigate to /home/bhaskar/work/phytec/src/OpenBoard-
AM335xPD13.0.0/platformPHYCORE-AM335x/sysroot-cross/bin/qmake 

 
Note:here Navigate to the path of qmake in our PC.(referN 2.4) 
Select qmake then click on Open  

 
Double click on Version Name and give the Qt Version a descriptive name such as Qt  
4.7.4(sysroot-cross) See image below.  

 

 
       

Figure 2.1.1 
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Export the Toolchain Path(refer 2.3.3) 

 
Click the Tool Chains tab under Build & Run  

 
Click Add in the top right and add a GCC   

 
For Compiler Path select Browse  

 
Navigate to /home/bhaskar/work/phytec/src/arm-cortexa8-linux-gnueabi/bin 
 
Note:here navigate to the path where you have exported the tool chain 

 
Select arm-cortexa8-linux-gnueabi-gcc and click on open  

 

Repeat the process to select a debugger, you will find it at the same location:  

/home/bhaskar/work/phytec/src/arm-cortexa8-linux-gnueabi/bin/arm-cortexa8-linux-
gnueabi-gdb 

 

 

 

      Figure 2.1.2 
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Now lets setup our Target. While still in the Tools -> Options menu  

 
On the left side of the window, select the Linux Devices tab  

 

 

 

     Figure 2.1.3 

 

In Linux Devices: click the Device Configurations tab  

 
Click Add... in the top right and select Generic Linux device and click on Start Wizard  

 

 
 
      Figure 2.1.4 
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The Device Configuration Wizard Selection Dialog box comes up  
 

Change the name Generic Linux Device to give the device a unique name: AM335x  
 

Type in the IP address of the Embedded Linux Device. Type the IP address for your board, not the 
one shown in the screen capture.  

  

For Username type in root  

 
Make sure Authentication type is Password, but leave the password field blank.  

 

Click Next and click Finish  

 

 
 
      Figure 2.1.5 
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You should see that the target test passed, so you can close that window.  
 

 
 
      Figure 2.1.6 
 
 
Now we need to setup an SSH key so that the host can communicate with the target 
 
Still under the Device Configurations tab click "Generate SSH Key.."  

Select Key size: 1024  
 

Key algorithm RSA  
 

Then click Generate SSH Key in the SSH Key Configuration dialog box  

 

 
 
      Figure 2.1.7 
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Click Do not Encrypt key file  

 

 
 
     Figure 2.1.8 
 
 

Then click Save Public Key...  

 

 
 
     Figure 2.1.9 
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Just use the default name id_rsa.pub and Click Save and Click Close to close the Generate SSH 

Key window.  

 

 
 
     Figure 2.1.10 
 
Under the Device Configurations tab now click Deploy Public Key...  

 

 

 

     Figurer 2.1.11 
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Select the file just generated (should be under /home/bhaskar/.ssh)  

IMPORTANT 
 
You may need to right click and select show hidden files or Ctrl+h 

 

 

    Figure 2.1.12 

 

Select the file id_rsa.pub and click on Open, shortly a window should show up saying  

"Deployment finished sucessfully"  

 

 

  

     Figure 2.1.13 
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     Figure 2.1.14 
 
Close the window and Click OK to exit the Linux Devices Window 

2.2.Target Setup 

Host Setup 

First open the terminal (ALT+CTRL+T). 

2.2.1.Toolchain Insatallation 

 
This section explains how to install prebuilt toolchain binaries on the Host. Whereas building of 
Toolchain is explained in buidsystem section. 

 2.2.2.Downloading the Toolchain: 

 
Download the toolchain from the public ftp of PHYTEC from the link below. 
 
ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/tools/toolchain/arm-
cortexa8-linux-gnueabi.tar.bz2 

2.2.3.Export the Toolchain to Shell Path: 

 
Export the Toolchain to Shell Path 
 
Extract the toolchain that has downloaded, from terminal issue the following  
 
         $ tar –xvf arm-cortex8-linux-gnueabi.tar.bz2 
 
Now write a script that export the target Architecture and toolchain prefix as below.  
 
          $ vim env.sh 
 
In the file add the following lines  
  export PATH=$PATH:/home/<user>/<path to toolchain bin> 
             export ARCH=arm 
                       export CROSS_COMPILE=arm- cortex8-linux-gnueabi- 

 

ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/tools/toolchain/arm-cortexa8-linux-gnueabi.tar.bz2
ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/tools/toolchain/arm-cortexa8-linux-gnueabi.tar.bz2
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 Save and exit from the editor. Execute the script by issuing  
        $ . env.sh 
 
Note:  The command is “dot space env.sh”. Execute the above command for every new 
 shell where you are trying to start compilation of Linux kernel or bootloaders.  

Check whether the toolchain path is set or not by issuing  

  
 $PWD 
 
Displays the path,where you have set this  Toolchain path 

 
$ echo $PATH 

 
Above command displays the entire paths that are added to Shell PATH variable separated  
by colon ‘:’. See if your path is printed on the terminal. If you are not able to see your  
toolchain path repeat the steps from the beginning of this section.  
 

$ echo $PATH 

2.3.Building qmake using ptxdist 

2.3.1Download the PTX-dist packet from the following link: 

ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/buildsystems/ptxdist/ptxdist-
2012.03.0.tar.bz2 

Extract the above downloaded source 
 
$ tar -xvf ptxdist-2012.03.0.tar.bz2 

 

Go to downloaded folder 
 
$ cd ptxdist-2012.03 

 

Configure the packet 
 
$ ./configure 

 

When the configure script is finished successfully, to compile run 
 
$ make 
 
$ sudo make install 

2.3.2.Download the PTX-dist BSP source from following link: 

ftp://ftp.phytec.de/pub/Products/India/Cosmic-
AM335x/Linux/PD13.0.0/buildsystems/ptxdist/Cosmic-AM335x.PD13.0.0.tar.bz2 

 

Extract the source  
 
$ tar -xvf Cosmic-AM335x.PD13.0.0.tar.gz 

 

 

ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/buildsystems/ptxdist/ptxdist-2012.03.0.tar.bz2
ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/buildsystems/ptxdist/ptxdist-2012.03.0.tar.bz2
ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/buildsystems/ptxdist/Cosmic-AM335x.PD13.0.0.tar.bz2
ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/buildsystems/ptxdist/Cosmic-AM335x.PD13.0.0.tar.bz2
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Go to extracted folder  
 
$ cd  Cosmic-AM335x.PD13.0.0 

 

Select the toolchain   
 
$ ptxdist toolchain <path_of_toolchain_bin> 
 
Refer 1.3.3 to set the Toolchain path,copy and paste the path here 

 
Start the build 
 

$ ptxdist go 
  

 Check the qmake image at platform-phyCORE-AM335x/sysroot-cross/bin/qmake 
 

$ ls platform-phyCORE-AM335x/sysroot-cross/bin/qmake 
 

2.4.Setting Serial Console (Minicom) 

$ sudo minicom -s 
 

Select the option serial port setup from menu on terminal and press 'Enter' 
 
 
 
 
 
 
 
 
 
 
 
   

      
 
 
    Figure 2.4.1 
 
 
Using the options at left; make the setting as shown in the figure 3.2. For ex: Serial device –  
dev/ttsyS0, first press ‘A’ the cursor blinks at the particular line then change the device name to 
/dev/ttyS0 and press „ENTER‟. 
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Figure 2.4.2  

 
 
 

After making all changes like baud rate -115200, hardware control flow -No etc. that are required 
press „ENTER‟ to come out from the screen, now the previous screen will appear. 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
     
     
 
     Figure 2.4.3    
 
 
Now select the ‘Save setup as dfl’ it saves the setting as default. 
   
Now select ‘Exit‟ 
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      Figure 2.4.4 
 
It will take into ‘minicom’ the serial terminal. 

2.5.Set the ip for Cosmic-AM335x 

To see all the interfaces present on the open board 
 

$ ifconfig –a 
 
After this we got the particular interface then we have to configure it.  
 

$ ifconfig eth0 192.168.1.100 up 
 

where eth0 is the interface name. 
 
Again check whether it is configured or not 
 

$ ifconfig –a 
 

Then we have to set the gateway 
 

$ route add default gw 192.168.1.1 
 

To see the change in the gateway. 
 

$route 
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3. Application development 

3.1.Simple Demo Application: 

Open a New Project 

Under Forms, double click on phytec.ui This will bring up the widget editor.  

 

 

 

     Figure 3.1.1 

 

Find the label widget in the category of display widgets, left click and drag it on to the User 
Interface (UI).  

 

 

     Figure 3.1.2 

Type any name (PhytecIndia)  into the label widget and strech out the borders so you can see all 
the letters 
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Figure 3.1.3 

File->Save phytec.ui 

Now we need to check and update the build and run settings:  
 
On the left side vertical menubar select Projects  

 
Select the Build Settings tab and selct the Qt 4.7.4(sysroot-cross)Release for build 

configuration. 

 

 

 

     Figure 3.1.4 
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Figure 3.1.5 

 

Now under the Projects Mode select the Run Settings tab  

Under Deployment click Add and select Deploy to Remote Linux Host  

 
However you see the <no target path set> error 

 

 

 

    Figure 3.1.6 
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To fix the <no target path set> error do the following:  
Click on Edit on the left side vertical bar and click on Phytecindia.pro  

 
Add the two lines below to the bottom of Phytecindia.pro as shown in the screen shot below  

target.path  +=  /home/phytec 
INSTALLS  += target  

 

 

 

     Figure 3.1.7 

 

Select File -> Save  

Click on Projects on the left side vertical bar and you should now see the error is gone and 
replaced with  /home/phytec  

 
Now in the Run portion: Select Add -> terminal (on Remote Generic Linux Host) 
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     Figure 3.1.8 

 
Finally we are ready to run  

IMPORTANT 

 
If matrix is not running add -qws to the Arguments in Run Settings 

 Click the Green Arrow on the bottom left to run the project or Press Ctrl+R 

 Save all files if asked  

NOTE: To exit from the hello world running on the target, click on the "X" on the 

upper right menu bar. 

The Output can be seen in the connected LCD display. 

 

 

     Figure 3.1.9 
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3.2.Uart Read Application 

Open the Uart  project build it and run it on the target 

Down load the Source code of Uart from the following link: 
 
ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/src/apps/Qt_uart.tar.gz 
 
Select  File-> Open File or Project  

 
Open the obserail.pro file in the Qt_uart folder. 

 
 
     Figure 3.2.1 

 
 

Click on Edit on the left side vertical bar and click on obserial.pro 
 

Add the two lines below to the bottom of obserial.pro as shown in the screen shot below 
 

 
 
     Figure 3.2.2 
 

 

ftp://ftp.phytec.de/pub/Products/India/Cosmic-AM335x/Linux/PD13.0.0/src/apps/Qt_uart.tar.gz
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target.path += /home/naga 

INSTALLS += target 

Select File -> Save  

Now we need to check and update the and run settings:  
 
Now under the Projects Mode select the Run Settings tab  

Under Deployment click Add and select Deploy to Remote Linux Host  
 
Now in the Run portion: Select Add -> obserial (on Remote Generic Linux Host) 

 
 
 
     Figure 3.2.3 

 
Now on host side (power up the target if not and make proper settings and make sure Ethernet 
wire is connected on target side) 

To login to the target give the following command 

  $ssh root@<ipaddress of target> 

 
 

     Figure 3.2.4 

Now you are in target 

 
 
     Figure 3.2.5 
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Go to the path which we mentioned in bottom of the .pro file in Qt creator 
 

i.e,target.path += /home/naga (see the following image.) 
 

 
 
     Figure 3.2.6  
 
 
 

$cd /home /naga 
 

 
 

     Figure 3.2.7 
 
Now execute the output file $./obserial -qws 

 
$./obserial –qws 
 

 
 
     Figure 3.2.8 
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Now you will see the console in LCD display 
 

First connect the usb hub to the target and then connect Mouse and Keyboard to that hub. Click on 
the setting icon (which is third icon in the below row) 

 

 
 
     Figure 3.2.9 
 
Set the Baud rate (The baud rate in LCD display should match the baud rate in serial port settings 
in target) 
 
Set the serial port settings in LCD display (preferably ttyO0) 

 
Click on the Apply 
 
Click on the  icon(connect to serial port) which is first icon in the below row 
 
Now type any letters on keyboard which is connected to usb hub, it visible on terminal of the  LCD 
display 
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     Figure 3.2.10 
 
 
Open the minicom and login to the board 
 
The same will be displayed on the minicom 
 

 
 
     Figure 3.2.11 
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